July 3, 2010

Update

Ok, I haven't made any posts in a while, and I finally have a opportunity to explain way. As of right now, whenever I go to edit a post on here, my entire browser just goes blank. Just white. Yeah, it's that annoying.

So I have had no capacity to actually make posts from home. Furthermore, my job had no computer for me to use, and my best friend's computer, and his room-mate's computer, both crashed, and I just haven't had the time to go to the library.

A quick update though is that I now have a new job! I've been job searching for about 3 years now, only working at Burger King. I've been mostly looking for a pastoral position, but I was unable to really find anything that would work. However, I just got a job as a resident counselor for Christian Heritage Services. This means that I am working assisting those with developmental disabilities. In my case, I am working with those who also have aging disorders (dimentia, etc...).

So far it's been fun, and I have access to a computer :). I hope to eventually figure out what's wrong with my home computer, but I only have a problem with blogger, so we'll see.

6 comments:

William Watson Birch said...

Glad to have you back. You have been sorely missed!

Kevin Jackson said...

I second Billy's thoughts. Congrats on the new position too. On the blank issue, have you tried different browsers, like Firefox or Chrome? How about deleting all the cache and cookies? Sorry if you've tried all this, just my IT mode kicking in. ;)

drwayman said...

or missed sorely :-)

Jc_Freak: said...

Thanks guys.

I have tried other browsers. It doesn't work in Chrome or firefox, but it work in IE. But I have other problems with IE which makes it a problem.

I haven't tried deleting the cache and cookies yet. I'll try that later today. Why would that be a factor?

Kevin Jackson said...

Now that you mention it, I can't think why it would be a factor. Resetting the browser to default might help, but probably the cache and cookies won't help.

Dan Martin said...

Cookies won't help but cache might. Uninstalling Firefox completely--first run the uninstall and when it's done, reboot, then delete the whole Mozilla\Firefox folder in Program Files--and finally re-installing a fresh new copy may also help.

Glad you've got a job now...having just taken a new job back in Public Health I am elated to be back in my profession of choice myself...though thankfully I never had to work at BK...

I'm fascinated that you're working with folks that have developmental disabilities. That world was never on my radar screen till I had a son with Down syndrome...then suddenly we became those "other people" that things happen to. It's an adventure! Thank you for being willing to serve a particularly overlooked part of "the least of these..."